Instalando Tilda 0.9.6

Buenas a todos! ¿qué tal habéis estado éste tiempo? He visto que misteriousman ha ido poniendo algún post de vez en cuando para mantener, por lo menos, el encefalograma plano de beGNU.

Yo todavía no he terminado el proyecto, aunque de momento va por buen camino, o eso parece porque hemos ganado el Primer Premio del Concurso Universitario de Software Libre Nacional en la categoría de innovación😀

Ya sé que hace mucho que no escribo (de hecho, hasta ahora no había visto la interfaz del nuevo wordpress que hay por aquí… jeje), pero hoy me he encontrado ésto y como tiene algo de chicha me apetecía ponerlo.

La versión 0.9.6 de Tilda no está en los repositorios de Ubuntu, está la 0.9.5, entonces… ¿por qué deberíamos instalar la nueva si es más complicado? Pues porque corrige ciertos bugs que nos pueden tocar un poco las narices en la Ubuntu 8.04. En mi caso tenía problemas con el foco de la ventana, es decir, tenía que sacar Tilda dos veces seguidas (sacar, ocultar y sacar) para que obtuviera el foco y claro…es un poco coñazo.

En su momento no me di cuenta de mirar si la versión de los repositorios era la última y di por supuesto que sip, así que le mande un mail a su desarrollador Tristan Sloughter, comentandole mi problema. Es un buen tio, me contestó dentro de las 24horas siguientes y me dijo que eso no pasaba en la 0.9.6, me puse manos a la obra y en rato pude mandarle un mail confirmándolo y dándole las gracias.

Os dejo los comandos para instalarla:

wget http://downloads.sourceforge.net/tilda/tilda-0.9.6.tar.gz

sudo aptitude install flex libgtk2.0-dev libglade2-dev libvte-dev libconfuse-dev build-essential

Con ésto tendremos el tarball del código fuente descargado y las dependencias satisfechas. Vamos con la compilación y la instalación:

tar zxvf tilda-0.9.6.tar.gz

cd tilda-0.9.6

./configure

make

sudo make install

Y listo, sólo tenéis que ejecutar tilda en el terminal para que funcione correctamente😀

  1. Me tira este error :S

    “checking for GTK… configure: error: Package requirements (gtk+-2.0 >= 2.0.0) were not met:

    No package ‘gtk+-2.0’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GTK_CFLAGS
    and GTK_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.”

    :S Idea de qué tengo que hacer? (uso linux hace tiempo, pero no engo experiencia :S)

  2. ¿has ejecutado la linea linea de aptitude? Ese error tiene toda la pinta de que te falta el libgtk2.0-dev.

    La linea esa larga de “sudo aptitude install…” debería instalártelo sin problemas.

    Si no la has ejecutado mira a ver si con un:

    sudo aptitude search libgtk2.0-dev

    te aparece. Si no te aparece es que tienes algo mal en los repositorios.

    • Loloto
    • 6/12/09

    compile e instale sin errores pero al ejecuatr me arroja Segmentation fault
    ya trate de intentarlo borrando el archivo de .tilda/config_0
    ¿alguna ayuda?

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: